Error codes on a gen 1 clock any ideas

bimota

Moderator
Staff member
Global Moderator
Joined
Dec 10, 2017
Messages
6,919
Location
bridgend, Wales, UK
Hi guys,

had my gen 1 bike 10 yearsalways rode perfectly and i thought but may be wrong that if a error code came up while riding or parked up , when you turned the clocks on you would see a error code showing, but after a mechanic fitting McCRUISE to my bike i have the orange engine trouble light coming on every time you ride it at about 15-20 miles and staying on.
anyway its back at the garage being looked at hopefully with Mc CRUISE helping the mechanic, anyway mccruise wanted to know what error code was showing to help them find the issue, i have never ever looked at the gen 1 clock and gone through buttons to see error codes as its never flagged one while riding or turning ignition on
but yesterday the mechanic went into diag and cleared what he said was alot of historical error codes, he,s going to ride the bike later to see what error code come on
when that warning light reappears at about 15-20 miles so mccruise know wxactly the error code

I can,t understand how in 10 years and the bike never missing a beat and while riding or turning on the ignition there are alot of historical error codes
is that strange

rob
 

Chav

Active Member
Joined
Aug 25, 2023
Messages
153
Location
Illinois
I didn’t even know you could go in and see error codes. What’s the process for this?
 

bimota

Moderator
Staff member
Global Moderator
Joined
Dec 10, 2017
Messages
6,919
Location
bridgend, Wales, UK
What error code number appear?
the bike is at the shop, while looking today for a error code that is causing the orange warning light to come on after fitting mccruise the mechanic said there were alot of historical error codes, he,s cleared them off so he can ride the bike to see why the engine trouble warning light is coming on after a 15 mile ride and staying on and see what code its bringing up so mccruise can help out.

i just thought it strange that for 10 years the bike has ridden perfectly no issues at all, and no error codes showed on the dash while riding it,
i thought if there was a issue with something the error code would show up on the dash when you turned it on or riding to show you may have a issue, i have never spent 5 minutes going into diag on the gen 1 looking for codes as i,ve never had a issue to need to.

i,m hoping today with codes gone and cleared that when the bike is ridden for 15 miles etc that the orange light comes on again to throw a code so we can see whats wrong with the mccruise installation

rob
 
Last edited:
Top