**17 LEFT** Gen2 Windscreen brackets to stop vibrations

Joined
Jan 9, 2019
Messages
14
Likes
1
Do you still have the black brackets fo a 2017 s10 ? I put on a parabellum windscreen, will these work with it? Will you accept a check in the mail? I’m a newby to super tenere.com.
 
Joined
Feb 11, 2014
Messages
189
Likes
21
Location
Appleton, WI
Yes, they are still available. They fit 2014+. I don’t know what your windscreen looks like, but it should not be a problem. There are pics at the beginning of this thread.

Yes a check is fine.

Tom Propson
15 Reef Court
Appleton, WI 54915
 
Joined
Jan 9, 2019
Messages
14
Likes
1
Yes, they are still available. They fit 2014+. I don’t know what your windscreen looks like, but it should not be a problem. There are pics at the beginning of this thread.

Yes a check is fine.

Tom Propson
15 Reef Court
Appleton, WI 54915
$30 ?? I’m in Iowa I’ll get you a check out Monday Thanks
 
Joined
Oct 2, 2018
Messages
9
Likes
30
Location
Czech Rep.
Hi Tom,
package successfully delivered ;)
I'm looking forward to the test ride, but it's cold and snow yet. Perhaps in a few weeks ...

Thanks and best regards!
Bolek
 

dmulk

Active Member
Joined
Jul 21, 2016
Messages
300
Likes
162
Location
San Diego, Ca
Received my brackets fast, thank you!

Finally got around to attempting install this weekend and seem to have run into the same issue that some have complained about here. There seems to be a fitment/clearance issue that some have complained causes their wind screen to move after riding.

I pulled the bracket apart more than is required to install these to attempt to find the issue.

Unless I'm doing something wrong with the install (which is entirely possible) there seems to be an interference issue with the units I received...specifically with the lower support post.

I tried to attach some photos illustrating the issue.

MVIMG_20190210_154750_exported_5662097810879171729.jpg

MVIMG_20190210_154737_exported_8825823836942607737.jpg
Please not that my winglets are currently attached in the photo but I've also tried without winglets with the same result.

It seems that this problem could be sorted by increasing the cut a bit.

I'm not sure if this is just with some units or just mine but it explains why some people have reported wind screen slippage. Not allowing that slot to clear the lower post causes the tentioning mechanism to fail to fully engage in the locking holes.

Thoughts?
 

thughes317

Active Member
Joined
May 27, 2018
Messages
97
Likes
112
Location
Western NY
Yeah, same here but I after much consideration I opted not to attempt modifying mine but instead followed the advice to "just crank the adjuster wing nuts f'ing tight as you can". They seem to hold without slipping when cranked really tight, just check 'em once in a while.
 

dmulk

Active Member
Joined
Jul 21, 2016
Messages
300
Likes
162
Location
San Diego, Ca
The only time mine loosend up prior to the brace was if I didn't have the alignment adjusted properly so the brackets were inside the rentention holes.

Anyway, I went the mod route:

MVIMG_20190210_161417_exported_6350660297284079548.jpg

MVIMG_20190210_161425_exported_3505239729710651314.jpg

If you ever make a second generation of these, I'd suggest cutting the pattern a bit lower to add some material below the bend/turn and running the slot a 1/4in to 3/8in longer. Modifying the current version makes the outside of the fork, near the bend/turn quite a bit thinner. I worry about some cracking in the future from the vibes but we'll see. Seems like a minor tweaks will make things fit a bit better and allow the retention holes to engage.

Thanks again for the efforts! :)

Dan
 

twinrider

Well-Known Member
Joined
Sep 28, 2011
Messages
1,362
Likes
93
Location
Yokohama
Yeah, same here but I after much consideration I opted not to attempt modifying mine but instead followed the advice to "just crank the adjuster wing nuts f'ing tight as you can". They seem to hold without slipping when cranked really tight, just check 'em once in a while.
I wasn't even aware of the slippage issue being discussed here, but the left side of my windshield was slipping down a bit so I just cranked it as f'ing tight as I could and it now seems to be fine.
 
Top Bottom