Recent content by stutrump

  1. S

    Suzuki T500

    Thanks Squibb. That will, I'm sure be very helpful. Will try to investigate more on Monday. I don't think it's the clutch either and the gear lever itself moves as it always has..it just doesn't engage a gear (1st or 2nd). Here's hoping I can fix it myself. It's a fun bike to ride and usually...
  2. S

    Suzuki T500

    Thanks folks. Working this weekend so it will probably be Monday before I can investigate further. All of your help is as always very much appreciated.
  3. S

    Suzuki T500

    Thanks WJBertrand. I'm worried that it might be similar for me but the shift lever feels the same as it always did with the same ammount of movement. Strange. Keep any ideas coming please folks. Thanks
  4. S

    Throttle tube issues

    I THINK the following has happened to me in the past: When changing grips you may turn the throttle to fully open several times and this might be something you haven't done for months of 'normal riding'. At the throttle body end (ie under the airbox) grime can build up where the throttle cables...
  5. S

    Suzuki T500

    Thanks folks. I've tried shifting with the engine off and still no difference. The shift lever does move through it's normal travel but doesn't 'click' or engage a gear.
  6. S

    Suzuki T500

    Hi folks. I'm after some wisdom please. Got my T500 out today. Started first kick but wouldn't engage gear (1st or 2nd). Any ideas what it could be? Thanks in advance for any help.
  7. S

    Guzzi V85 test ride

    Hi Folks. In answer to a few questions. My test ride was almost entirely dual carriageway (deliberately because I do lots of miles all year round on highway). Pretty sure the tyres were NOT noisy but there was so much buffeting/wind noise in my helmet I'm not 100 percent sure. Tyres didn't feel...
  8. S

    Guzzi V85 test ride

    So I went on a date with a young Italian thing this morning. The S10 didn't mind coz the S10 still wins hands down for the kind of riding I do... BUT..the Guzzi is one of the best looking bikes I've seen for a long time. Really, really pretty. Super smooth gearbox/clutch, nice sound, good...
  9. S

    Hard start after oil change, now only idles?

    Pleased it's sorted!
  10. S

    Hard start after oil change, now only idles?

    I dont think I can help sorry but you mention at some point that you did WOT. Might be worth undoing the throttle cable housing (on the handlebar) and checking the cable is still seated properly??
  11. S

    What you did to your Tenere today??!!

    Hi Boris. About 20k in answer to your question
  12. S

    What you did to your Tenere today??!!

    Thanks Tabasco. I smother the coils in grease each time coz I had a coil seize in my last S10 I haven't tried sealant yet but could be a good idea coz it rains a LOT in uk!!
  13. S

    What you did to your Tenere today??!!

    Changed the sparkies. Looks like it was ready for some too!
  14. S

    They're suddenly everywhere!

    Only good people on Teneres. No...I'm a really horrible miserable old git
  15. S

    Bar End Weights

    Thanks Don. I didn't know that. Useful info!!
Top Bottom